Impacter Pathway - Some emails may be delayed – Incident details

Core Database experiencing degraded performance

Real-time status updates for Impacter Pathway's voice collection, scoring, and district access features. Any questions? Contact support.

Some emails may be delayed

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

The Platform

Degraded performance from 10:18 PM to 11:31 PM

System Notifications

Degraded performance from 10:18 PM to 11:31 PM

Updates
  • Resolved
    UTC
    Resolved
    Email notifications are sending normally again.
  • Investigating
    UTC
    Investigating
    Email notifications may arrive later than usual right now.