Impacter Pathway - Some emails may be delayed – Incident details

Core Database experiencing degraded performance

Real-time status updates for Impacter Pathway's voice collection, scoring, and district access features. Any questions? Contact support.

Some emails may be delayed

Resolved
Degraded performance
Started 18 days agoLasted 33 minutes

Affected

The Platform

Degraded performance from 5:14 AM to 5:48 AM

System Notifications

Degraded performance from 5:14 AM to 5:48 AM

Updates
  • Resolved
    UTC
    Resolved
    Email notifications are sending normally again.
  • Investigating
    UTC
    Investigating
    Email notifications may arrive later than usual right now.