Impacter Pathway - District login is having issues – Incident details

Core Database experiencing degraded performance

Real-time status updates for Impacter Pathway's voice collection, scoring, and district access features. Any questions? Contact support.

District login is having issues

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

Access

Degraded performance from 8:22 PM to 9:43 PM

Partner Sign-On Service

Degraded performance from 8:22 PM to 9:43 PM

Updates
  • Resolved
    UTC
    Resolved
    District login is working normally again.
  • Investigating
    UTC
    Investigating
    Some districts may have trouble logging in through their school system right now.